当前位置:首页 » Android开发技术

Error:Cause: org/gradle/api/publication/maven/internal/DefaultMavenFactory Android

2015-11-12 16:31 本站整理 浏览(3370)

大家都是间接或直接的开源参与者,经常会下载运行一些Android Stuido开源项目,此时部分童鞋可能会遇到下面这个无厘头问题了!当然解决办法很简单了....

当你使用的Gradle版本是2.4及以上,Android插件版本是1.3.0及以上的时候就会出现这个问题,这时候你只需将android-maven-gradle-plugin插件版本改为classpath

‘com.github.dcendents:android-maven-gradle-plugin:1.3’即可。

注意:有的童鞋偷懒只修改了版本号1.3,改成1.3会报错的,提示找不到1.3的版本。。,这样是不可以滴,因为地址也变了....当然找不到了。所以童鞋们继续重新修改吧....