当前位置:首页 » Linux技术知识

CentOS7.X 安装RabbitMQ3.6.15

2018-05-14 11:52 本站整理 浏览(6)

1. 环境说明

 

   操作系统:CentOS7.X

   RabbitMQ: 3.6.15

 

2. 环境要求

 

 erlang/OTP 19.3 ~ 20.3.X

 

3.安装erlang环境

    安装依赖包

 

yum -y install gcc gcc-c++ glibc-devel make ncurses-devel openssl-devel autoconf

   下载erlang源码包

 

wget http://erlang.org/download/otp_src_20.3.tar.gz

    安装erlang

   

$ tar -zxf otp_src_20.3.tar.gz
$ cd otp_src_20.3
$ ./otp_build autoconf
$ ./configure
$ make && make install

 

4. 安装rabbitmq-3.6.15

 

 

$ wget https://github.com/rabbitmq/rabbitmq-server/releases/download/rabbitmq_v3_6_15/rabbitmq-server-3.6.15-1.el7.noarch.rpm
$ yum install rabbitmq-server-3.6.15-1.el7.noarch.rpm
$ chkconfig rabbitmq-server on  #开机启动
$ /sbin/service rabbitmq-server start #启动服务
$ /sbin/service rabbitmq-server stop #停止服务
$ systemctl restart rabbitmq-server.service #重启服务

 

5. 启用web管理界面

 

rabbitmq-plugins enable rabbitmq_management  #需要在rabbitmq服务运行的情况下执行

 

常见问题

解决用户只能本地登录的问题

vim /usr/lib/rabbitmq/lib/rabbitmq_server-3.6.15/ebin/rabbit.app
{loopback_users, []} #调整内容,将原来的guest删除